题目:http://poj.org/problem?id=3255

Roadblocks
Time Limit: 2000MS		Memory Limit: 65536K
Total Submissions: 28456		Accepted: 9683
Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output

450
Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

题目大意就是某个街区有R条路,N个路口,并且道路可以双向通行,问1号路口到n号路口的次短路长度。并且,同一条边可以经过多次。

次短路就是长度第二短的路。

其实这题就可以通过Dijkstra来求解,只需要做少量更改。

分析知,到e.to的次短路有两种情况

  • 是起点到v的最短路 + v到e.to的边
  • 是起点到v的次短路 + v到e.to的边

上面这个关系可以思考一下,比较难想。为什么次短路可以是上一个点的次短路+与当前点的连边呢?

举个例子,上一点的最短路长度为5,次短路长度为6。与当前点的最短连边为1.(不一定是要最短连边)

那么当前点的次短路就是7了,这就是上面的第二种情况。

然后使用优先级队列进行优化,时间复杂度为O(ElogE)

AC代码

#include <cstdio>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;

#define MAXN 5005
#define MAXR 100005
#define INF (1 << 30)
typedef pair<int, int> P;

struct edge
{
    /* data */
    int to, cost;
    edge(int t, int c)
    {
        to = t;
        cost = c;
    }
};

vector<edge> G[MAXN];

int dist[MAXN];  //最短距离
int dist2[MAXN]; //次短距离

int n, r;

int main()
{
    scanf("%d%d", &n, &r);

    int a, b, d;
    for (int i = 1; i <= r; ++i)
    {
        scanf("%d%d%d", &a, &b, &d);
        G[a].push_back(edge(b, d));
        G[b].push_back(edge(a, d));
    }

    priority_queue<P, vector<P>, greater<P>> q;
    fill(dist, dist + n + 1, INF);
    fill(dist2, dist2 + n + 1, INF);

    dist[0] = 0;
    dist[1] = 0;
    q.push(P(0, 1));

    while (!q.empty())
    {
        P p = q.top();
        q.pop();
        int v = p.second;
        int d = p.first;

        if (dist2[v] < d)
            continue;

        for (int i = 0; i < G[v].size(); ++i)
        {
            edge &e = G[v][i];
            int d2 = d + e.cost;
            /**
             * 到e.to的次短路有两种情况
                * 是起点到v的最短路+v到e.to的边 
                * 是起点到v的次短路+v到e.to的边
            */
            if (dist[e.to] > d2)
            {
                //更新到e.to的最短路,这里使用swap的目的是,把原来的最短路更新,并使其在下一个if中,能够成接下来的次短路。
                swap(dist[e.to], d2);
                q.push(P(dist[e.to], e.to));
            }
            if (dist2[e.to] > d2 && dist[e.to] < d2) //在d2不是最短路,且当前次短路不是最优的情况下,更新次短路
            {
                dist2[e.to] = d2;
                q.push(P(dist2[e.to], e.to));
            }
        }
    }

    printf("%d\n", dist2[n]);
}

转载请注明来源:https://www.longjin666.top/?p=1132

欢迎关注我的公众号“灯珑”,让我们一起了解更多的事物~

你也可能喜欢

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注